Browse Source

feat: require Wagtail >=2.15

main
Jérôme Lebleu 6 months ago
parent
commit
58f3ad5ce7
  1. 8
      README.md
  2. 2
      setup.cfg
  3. 4
      tox.ini

8
README.md

@ -14,16 +14,10 @@ will be able to display it in a page - e.g. as a StreamField block. @@ -14,16 +14,10 @@ will be able to display it in a page - e.g. as a StreamField block.
## Requirements
This package requires the following:
- **Wagtail >= 2.14**: upstream patches have been submitted to provide a proper
integration of this extension into the admin - see [#7562], [#7565] and
[#7590]
- **Wagtail** >= 2.15
- **Django** (3.1, 3.2)
- **Python 3** (3.7, 3.8, 3.9)
[#7562]: https://github.com/wagtail/wagtail/pull/7562
[#7565]: https://github.com/wagtail/wagtail/pull/7565
[#7590]: https://github.com/wagtail/wagtail/pull/7590
## Installation
1. Install using ``pip``:

2
setup.cfg

@ -30,7 +30,7 @@ keywords = @@ -30,7 +30,7 @@ keywords =
[options]
include_package_data = True
install_requires =
wagtail >=2.14
wagtail >=2.15
packages = wagtail_maps
python_requires = >=3.7, <4
setup_requires =

4
tox.ini

@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
[tox]
envlist =
python{3.7,3.8,3.9}-django{3.1,3.2}-wagtail{2.14,main}
python{3.7,3.8,3.9}-django{3.1,3.2}-wagtail{2.15,main}
[testenv]
commands = {envpython} -m pytest --basetemp="{envtmpdir}" --cov --cov-report=term:skip-covered
@ -14,7 +14,7 @@ deps = @@ -14,7 +14,7 @@ deps =
django3.1: Django>=3.1,<3.2
django3.2: Django>=3.2,<3.3
wagtail2.14: wagtail>=2.14,<2.15
wagtail2.15: wagtail>=2.15,<2.16
wagtailmain: git+https://github.com/wagtail/wagtail.git
extras = test

Map all the world